How Tos & Tipps

“Windows to go” auch ohne Windows 8 Enterprise auf einen USB-Stick bringen

windows-to-go-windows-8

Vor drei Tagen erst habe ich “Win­dows to go” er­kund­schaftet: Nettes Fea­ture, das leider nur mit Win­dows 8 En­ter­prise da­her­kommt. WtG ist ein kom­plettes Win­dows 8 System auf eurem USB-Device, dass ihr an jeden be­lie­bigen Rechner an­ste­cken und von dort aus booten könnt. Auf dem Rechner bleiben kei­nerlei Spuren und Daten zu­rück, alles bleibt auf eurem Gerät. Quasi wie euer ei­gener Laptop, nur kleiner. Aber wie ge­sagt: So ohne wei­teres klappt die Ein­rich­tung nur mit der Enterprise-Version von Win­dows 8. So ohne wei­teres. Mit ein paar kleinen Tricks be­kommen wir aber trotzdem Win­dows 8 voll­ständig vom USB-Stick zu laufen. Vor­raus­set­zungen dafür sind jedoch:

Habt ihr alles her­un­ter­ge­laden und Win­dows 7 ge­startet? Dann kann’s ja losgehen…

Ales aller erstes In­stal­lieren wir unser vir­tu­elles Lauf­werk und mounten die her­un­ter­ge­la­dene ISO-Datei des Au­to­mated In­stal­la­tion Kit. Nun starten wir die Setup.exe von un­serer vir­tu­ellen DVD und wählen das “Win­dows AIK-Setup”. Im auf­pop­pendem Dialog könnt ihr ein­fach immer auf “Weiter” kli­cken, hier muss nicht ein­ge­stellt werden.

Nach der In­stal­la­tion – die nur ei­nige Se­kunden dauert – könnt ihr das Image gerne wieder aus­werfen und lö­schen. Wir wech­seln dafür in den Ordner “C:\Program Files\Windows AIK” und ko­pieren uns den Ordner “Tools” auf den Desktop. Nicht, dass es von Be­lang wäre, aber so wird es ein wenig ein­fa­cher.

Nun ste­cken wir unser USB-Gerät ein und warten, bis Win­dows die Er­ken­nung ab­ge­schlossen hat – dann öffnen wir die Ein­ga­be­auf­for­de­rung als Ad­mi­nis­trator. Ent­weder han­gelt ihr euch durchs Start­menü in den Ordner “Zu­behör”, oder ihr tippt ein­fach “cmd” (ohne An­füh­rungs­striche) ein.

In der Ein­ga­be­auf­for­de­rung geben wir nun den Be­fehl diskpart ein. Es dauert eine Weile bis die An­wen­dung ge­startet ist und wir schießen den Be­fehl lis dis hin­terher. Nun werden uns alle an­ge­schlos­senen Ge­räte an­ge­zeigt, wobei “Daten­träger 0″ in der Regel das Sys­tem­lauf­werk ist. Wel­ches Lauf­werk nun unser USB-Gerät ist er­kennen wir je­doch an der Speichergröße:

In diesem Falle wäre “Daten­träger 1″ eben mein USB-Laufwerk in Form einer ex­ternen Platte. Dieses Gerät wählen wir nun mit­tels Be­fehl sel dis 1 (wobei ihr die 1 durch eure Ziffer er­setzen solltet!) aus:

Nun lassen wir uns mit lis par die Par­ti­tionen auf­listen. In der Regel be­sitzen USB-Sticks und -Fest­platten nur eine Par­ti­tion 1. Diese wählen wir mit sel par 1 aus und lö­schen diese dann mit dem Be­fehl de­lete par­ti­tion. Solltet ihr meh­rere Par­ti­tionen an­ge­zeigt be­kommen (zum Bei­spiel weil die Fest­platte mal als Sys­tem­lauf­werk fun­giert hat), solltet ihr statt de­lete par­ti­tion den Be­fehl clean nutzen. Je nach Größe des Ge­rätes kann dies na­tür­lich etwas dauern.

Nun er­stellen wir die Par­ti­tionen neu und geben dafür create par­ti­tion pri­mary ein – auf dieser Par­ti­tion landen später die Windows-Dateien. Dazu müssen wir die na­tür­lich for­ma­tieren, was wir mit dem Be­fehl format fs=ntfs quick erledigen.

Mit dem Be­fehl ac­tive schalten wir die Par­ti­tion “aktiv” und können da­nach mit exit die Daten­trä­ger­par­ti­tio­nie­rung beenden.

Das Lauf­werk ver­schwindet nun aus eurem Ar­beits­platz – ihr müsst nun erst einmal wieder dem Lauf­werk einen Buch­staben zu­ordnen. Dazu öffnen wir die Com­pu­ter­ver­wal­tung (im Start­menü “Com­pu­terv” ein­geben) und wählen in der linken Über­sicht die Daten­trä­ger­ver­wal­tung aus. Euer Lauf­werk solltet ihr nun schnell finden können: Ohne Buch­stabe, Spei­cher­platz… Hier wählen wir nun “Lauf­werks­buch­staben und -pfade än­dern” und fügen einen Lauf­werks­buch­staben hinzu:

Das USB-Laufwerk wäre nun also vor­be­reitet, nun ma­chen wir uns an die Win­dows 8 Daten. Dazu mounten wir nun das Win­dows 8 Image und wech­seln wieder in die Ein­ga­be­auf­for­de­rung. Nun müssen wir in den “Tools”-Ordner auf dem Desktop wech­seln, was am ein­fachsten mit dem Be­fehl cd c:\users\EuerBenutzername\
Desktop\Tools\x86
klappt. Al­ter­nativ könnt euch ihr auch mit­tels “cd ..” zu­rück­wech­seln und mit “cd” und der Ta­bu­lat­or­taste durch die ein­zelnen Ordner hangeln:

Für den nächsten Schritt be­nö­tigen wir die Lauf­werks­buch­staben eures vir­tu­ellen Lauf­werks mit dem ge­moun­tetem Image, sowie den Buch­staben eures USB-Laufwerks. Mit dem Be­fehl imagex.exe /apply e:\sources\install.wim 1 f:\ ko­pieren wir nun die Windows-8-Daten auf das Lauf­werk. Be­achtet dabei aber die Lauf­werks­buch­staben: e:/ ist bei mir das vir­tu­elle Lauf­werk, f:/ das USB-Laufwerk. Die Buch­staben müsst ihr na­tür­lich an eure Lauf­werks­buch­staben an­passen!

Der Vor­gang kann durchaus etwas Zeit in An­spruch nehmen, aber fertig wird es schon, keine Sorge. Wenn der Vor­gang ab­ge­schlossen ist, er­stellen wir mit­tels bcd­boot f:\windows /s f: den Boot­be­reich auf dem USB-Laufwerk. Auch hier wieder: Er­setzt f:/ durch den Buch­staben eures USB-Laufwerks!

So­bald die Mel­dung “Boot files suc­cess­fully created” er­scheint, ist euer Win­dows 8 fertig. Ihr könnt nun den Rechner neu starten und nun vom USB-Laufwerk booten lassen (ent­weder per dau­er­haftes Än­dern oder per Boot­loader – letz­teres ist mein Fa­vorit). Nun müsst ihr es nur noch ein­malig Ein­richten und schon könnt ihr euer “Win­dows to go ohne Win­dows 8 En­ter­prise” nutzen. Have fun.

[blue_box]Nach­trag: Dies ist na­tür­lich kein “echtes Win­dows to Go” und funk­tio­niert auch mit Win­dows 8 Core und Win­dows 8 Pro. Ihr be­nö­tigt in dem Falle aber immer eine extra Li­zenz für den Stick, egal ob ihr euer Win8 auf dem Rechner ak­ti­viert habt oder nicht…[/blue_box]

Geschrieben von

Marcelismus. Hobby-Blogger aus dem Rheinland in den besten 20er Jahren. Appletisiert, aber immer mit einem gesunden Blick über den googlefizierten Tellerrand. Fetischist schicker User Interfaces und Fan von Dingen, die oftmals keinen Nutzen haben, die aber blau leuchten können.

WindowsUSBwindows to go

8 Kommentare

  • http://www.mh-nrw.de Mirco

    Also die Über­schrift ist ja doch ziem­lich ver­wir­rend, da man ja das Win­dows 8 Enterprise-Image be­nö­tigt, aber halt keine volle In­stal­la­tion braucht.

    Zwei Fragen gäbe es dann noch zu klären:
    1. Ist diese WtG-Version dann auch nur 90 Tage lauf­fähig, wie die Ver­sion die aus der Enterprise-Test-Version er­stellt werden kann? Stich­wort: Se­ri­en­nummer
    2. Wird das mit an­deren Win­dows 8-Versionen auch funk­tio­nieren? So habe ich es jetzt zu­min­dest verstanden.

  • http://www.blogtogo.de Marcel

    Naja, in der Regel be­nö­tigst du für “Win­dows to go” die Enterprise-Version. Klaro, be­nö­tigt man hier nun das Enterprise-Image, ist aber auch das ein­zige Image, an das ich ohne TechNet- und MSDN-Account ran­komme. Klappt also im Prinzip auch ohne Enterprise-Image.

    Die “Win­dows to go”-Versionen sind immer nur so lang lauf­fähig wie die “ori­gi­nale” Ver­sion. Wenn eine gül­tige Li­zenz für En­ter­prise vor­liegt, ist “Win­dows to go” damit ab­ge­golten – sind ja eh Volumenlizenzen.

    Macht man diese Schritte mit Win­dows 8 Core zum Bei­spiel, be­nö­tigt man für die In­stal­la­tion auf dem Rechner UND für den Stick _jeweils_ eine ei­gene Li­zenz – ist ja kein “echtes” WtG…

  • Stefan

    Hi Marcel,

    würde das ganze auch funk­tio­nieren wenn ich an­statt des Win8 Images ein Win7 oder sogar ein XP Image ver­wenden würde.

    Danke!
    Stefan

  • http://www.blogtogo.de Marcel

    Nope. Win­dows 8 ist u.a. darauf aus­ge­legt von einem USB-Gerät zu starten und zu laufen. Win­dows 7/XP nicht.

  • Stefan

    Hi Marcel,

    hab das heute mal mit einem Win 8 Pro Image pro­biert und dass funk­tio­niert nicht. Hast du da eine Ahnung?

    Danke!

    Stefan

  • http://www.blogtogo.de Marcel

    Meine Glas­kugel ist ka­putt. Was und wo funk­tio­niert denn nicht?

  • Stefan

    Hi Marcel,

    wenn ich das Win8 Pro Up­grade image nehme und den fol­genden Be­fehl (imagex.exe /apply e:\sources\install.wim 1 f:\) aus­führe kommt fol­gende Meldung:

    “Error opening file [e:\sources\install.wim].

    Das System kann die an­ge­ge­bene Datei nicht finden.”

    Nehm ich wieder das En­ter­prise Image gibts keine Probs…

    Danke!

    LG
    Stefan

  • Stefan

    Weißt du was?

    LG
    Stefan